Failure [INSTALL_FAILED_OLDER_SDK]

はじめに

Ionicのアプリをデバイスにインストールしようとしたところ、

Failure [INSTALL_FAILED_OLDER_SDK]

のエラーが発生しました。 config.xmlのの設定を色々変えて試しましたが、解消しませんでした。

対応方法

platforms/androidの中にある、build.gradeのdefaultMinSdkVersionを書き換えます。

project.ext {
      defaultBuildToolsVersion="25.0.2" //String
      defaultMinSdkVersion=19 <==ここのバージョンを変更する。
      defaultTargetSdkVersion=26 //Integer - We ALWAYS target the latest by default
      defaultCompileSdkVersion=26 //Integer - We ALWAYS compile with the latest by default
    }

以上

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です